We were asked by a regular customer with an Audi RS6 if we could take a look at a very frustrating problem on his car. The vehicle is a low mileage which is still under manufacturer’s warranty having only covered 13,000 miles.

20180504_132754         View of the RS6 engine bay A.B.S plug on the right hand side

The story was that the owner had experienced an intermittent fault where the four wheel steering light would come on followed by just about every warning light on the dash.  As the car was under warranty the customer had booked it in with his nearest dealer to try and resolve these issues. After three weeks the car was returned but the problem was still there although the dealer had originally diagnosed a faulty A.B.S. controller when they had fitted a new one they couldn’t code it to the car.

Our initial diagnostic process revealed multiple communication faults and the common denominator appeared to be the A.B.S controller. There was also logged a low voltage to the controller which could easily cause a communication issue.

After clearing the faults and several road tests and starting the car over two days there always seemed to be an issue when starting from cold on the first start. The fault was quite difficult to replicate but there was now emerging a pattern.

After consulting the owner we formed a plan to investigate further. We obtained the relevant wiring information on line from Audi for the A.B.S controller and started with load testing all the feeds and grounds. We discovered that one twelve volt feed on pin seven would not carry current and after load testing the fault was then permanent. We substituted the supply and all faults would clear this was now a confirmed fault all we had to do now was find the cause

 

Audi RS6   Manufacturers wiring information

Looking through the wiring information we could see that this voltage supply came from a fuse number twelve in the driver’s side fuse board. We testing the supply at source and it was perfect.

The wiring from the A.B.S control unit is routed under the passenger side wing under the wheel arch liner and then through the A post into the car behind the screen washer bottle. Tracing the wiring inside the vehicle we located the wire inside the main loom close to the A post and carried out a continuity test back to the fuse board and it was perfect we then knew that the fault was between the wiring inside the car at the A post back to the control unit .

Stripping out the wheel arch liner and the washer bottle we were able to unclip the large rubber grommet inside the car and pull the wiring loom through this is when we found the fault the wire when installed had looped back on itself and been damaged . A small amount of moisture had crept into the loom via the washer bottle and corroded the wire causing the volt drop. Carefully we cut out a section of loom and soldered in a new wire suitably insulated we retested the repair and then reassembled the car.

20180504_132717

Broken wire at A post

20180504_145234

Wiring repaired

 

 

20180504_154859

Wiring to ABS controller

20180504_151536

Fuse board supply to A.B.S

 

Conclusion: – careful diagnostic testing with a structured approach was the key to correctly diagnosing and repairing this fault and yes we could fix what the dealer couldn’t .